re = /(?xsm) # free-spacing mode, multi-line
(?=.*?pig) # fail right away if pig isn't there
(?=
( # Group 1
(?: # skip one line that doesn't have pig
^ # beginning of line
(?:(?!pig)[^\r\n])* # zero or more chars not followed by pig
(?:\r?\n) # newline chars
)
(?:(?1)|[^:]+) # recurse Group 1 OR match all chars that are not a :
(:\d+) # match a sequence of digits
)? # End Group 1
) # End lookahead. Group 1, if set, now contains the number of lines skipped
.*?\Kpig # match pig
(?=.*?(?(2)\2):(\d+))/
str = 'my cat pi g
dog pi g
my pig
my cow
my mouse
:1:2:3:4:5:6:7'
subst = '\\3'
result = str.sub(re, subst)
# Print the result of the substitution
puts result