# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"(?xsm) # free-spacing mode, multi-line\n"
r"(?=.*?pig) # lookahead: if pig is not there, fail right away to save the effort\n"
r"(?: # start counter-line-skipper (lines that don't include pig)\n"
r" (?: # skip one line that doesn't have pig\n"
r" ^ # beginning of line\n"
r" (?:(?!pig)[^\r\n])* # zero or more chars not followed by pig\n"
r" (?:\r?\n) # newline chars\n"
r" ) \n"
r" # for each line skipped, let Group 1 match an ever increasing portion of the numbers string at the bottom\n"
r" (?= # lookahead\n"
r" .* # get to the end of the input\n"
r" ( # start Group 1\n"
r" :\d+ # match a colon and some digits\n"
r" (?(1)\1) # if Group 1 is set, match Group 1\n"
r" ) # end Group 1\n"
r" ) # end lookahead\n"
r")*+ # end counter-line-skipper: zero or more times\n"
r".*? # match\n"
r"\K # drop everything we've matched so far\n"
r"pig # match pig (this is the match!)\n"
r"(?=.*(\d+)(?(1)\1)) # capture the next number to Group 2")
test_str = ("my cat pi g\n"
"dog p ig\n"
"my pig\n"
"my cow\n"
"my mouse\n\n"
":7:6:5:4:3:2:1")
subst = "\\2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.