import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?xsm) # free-spacing mode, multi-line\n"
+ "(?=.*?pig) # lookahead: if pig is not there, fail right away to save the effort\n"
+ "(?: # start counter-line-skipper (lines that don't include pig)\n"
+ " (?: # skip one line that doesn't have pig\n"
+ " ^ # beginning of line\n"
+ " (?:(?!pig)[^\\r\\n])* # zero or more chars not followed by pig\n"
+ " (?:\\r?\\n) # newline chars\n"
+ " ) \n"
+ " # for each line skipped, let Group 1 match an ever increasing portion of the numbers string at the bottom\n"
+ " (?= # lookahead\n"
+ " [^:]+ # skip all chars that are not colons\n"
+ " ( # start Group 1\n"
+ " (?(1)\\1) # if Group 1 is set, match Group 1\n"
+ " # (?>\\1?) # alternate phrasing for the above\n"
+ " :\\d+ # match a colon and some digits\n"
+ " ) # end Group 1\n"
+ " ) # end lookahead\n"
+ ")*+ # end counter-line-skipper: zero or more times\n"
+ ".*? # match\n"
+ "\\K # drop everything we've matched so far\n"
+ "pig # match pig (this is the match!)\n"
+ "(?=[^:]+(?(1)\\1):(\\d+)) # capture the next number to Group 2";
final String string = "my cat pi g\n"
+ "dog pi g\n"
+ "my pig\n"
+ "my cow\n"
+ "my mouse\n\n"
+ ":1:2:3:4:5:6:7";
final String subst = "\\2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}