$re = '/\"([^"]*)(?=\">\s*TEXT1)/';
$str = '<div class="CLASSNAME_1">
<span class="CLASSNAME_2"></span>
<div class="CLASSNAME_3">
TEXT1
</div>
</div>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);