import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!\\((\\'|\")*[^\"\\']+)\\s*,\\s*((?![^\"\\'(\\)]*(\\'|\")*\\)))";
final String string = "sdfsf,\n"
+ "sdfsdf,\n"
+ "asdsd(),\n"
+ "sdfsdf(3,33),\n"
+ "dfgdfgdg,\n"
+ "sdfsdf(\"hg,gh\"),\n"
+ "jhkjh(',k,k'),\n"
+ "jhkjh('sd,'),\n"
+ "jhkjh('sd'),\n"
+ "asdad(','),\n"
+ "asdasd(\",sss\"),\n"
+ "kjkj,\n"
+ "hghjg(\",jhgjh,h\"),\n"
+ "sdfsf:jhjh(\"\"),\n"
+ "sdfsf:jhjh(\"asd()asd,()\"),\n"
+ "hghjg(\",(\"),";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}