$re = '/(?!\([^\s*\,])\s*,\s*(?![^\s*\,])/';
$str = 'sdfsf,
sdfsdf,
asdsd(),
sdfsdf(\'3\',33,"22"),
dfgdfgdg,
sdfsdf("hg,gh"),
jhkjh(\',k,k\'),
jhkjh(\'sd,\'),
jhkjh(\'sd\'),
asdad(\',\'),
asdasd(",sss"),
kjkj,
hghjg(",jhgjh,h"),
sdfsf:jhjh(""),
sdfsf:jhjh("asd()asd,()"),
hghjg(",("),
hghjg(\',(WE2\'),
ASDASD,
sdfsf:jhjh("asd(), asd,(,)"),';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);