$re = '/(<a[^>]*href="(?!(http|ftp))[^"]*\/)([^"]+)/';
$str = '<a href="http://www.example.com/foo/bar.html">bar</a><a href="/foo/bar1.html"><a href="/foo/bar2.html">foo</a>
<a href="bar/foo3.html">foo</a><a target="_blank" href="../../bar/foo4.html">foo</a><a href="http://www.example.com/bar/foo.html">foo</a>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);