$re = '/^[0-9]{20}/';
$str = '09898987';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);