package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d+[^,\d]*_[^,]+, \S+`)
var str = `001 ALLAN Witham Ross 13 Every_Street, Welltown Greenkeeper 002 ALLARDYCE Margaret Isabel 49 Bell_Road, Musicville Housewife 003 ALLARDYCE Mervyn George 49 Bell_Road, Musicville Company Mngr `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}