re = /^formModalEditProps(\w+?)(Display)?$/m
str = 'formModalEditPropsAgeDisplay
formModalEditPropsWeight
abcFighz'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end