$re = '/^\s*\d+\s*$/m';
$str = '1234
111
111
1a234
aa1234aa
1234a
12#4
11 111
11 111#';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);