re = /^\w{3,}\s+(?:\w\s+)?\w{3,}/mi
str = 'John Doe
John M Doe
John Mr Doe
____ ____'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end