#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\w+(\s\w&\w)"
Local $sString = "Employee Communications & Engagement, WB" & @CRLF & _
"SVP of Global Insights & Analytics, WB" & @CRLF & _
"SVP of Nonfiction, HBO Max" & @CRLF & _
"VP of Talent Relations and Development, TCM" & @CRLF & _
"Global Franchise Management, DC" & @CRLF & _
"WB Technology Group" & @CRLF & _
"President, EMEA & APAC" & @CRLF & _
"SVP & CFO, EMEA & APAC" & @CRLF & _
"Director, Service Delivery" & @CRLF & _
"SVP for Sales and Client Partnerships, Legacy Turner" & @CRLF & _
"Technical Director, WarnerMedia" & @CRLF & _
"Dir. of Brand Distribution, WarnerMedia" & @CRLF & _
"Dir. Strategic & Consumer Insights, Turner Sports" & @CRLF & _
"Manager for Digital Asset & Photo Library, Brand Experience" & @CRLF & _
"Creative Manager for Creative Services, Cartoon Network" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"// 2 words" & @CRLF & _
"Cincinnati Bearcats" & @CRLF & _
"Miami (FL) Hurricanes" & @CRLF & _
"Miami (OH) Redhawks" & @CRLF & _
"" & @CRLF & _
"// three words " & @CRLF & _
"South Florida Bulls // 2.1 " & @CRLF & _
" Saint Joseph's Hawks" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"Duke Blue Devils // 1.2" & @CRLF & _
" UNLV Runnin' Rebels // with apostrophe" & @CRLF & _
"" & @CRLF & _
"// 4 words" & @CRLF & _
"North Carolina Tar Heels" & @CRLF & _
"Notre Dame Fighting Irish" & @CRLF & _
"St John's Red Storm" & @CRLF & _
"Florida A&M Rattlers" & @CRLF & _
"William & Mary Tribe" & @CRLF & _
"St Francis (PA) Red Flash" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")