package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\w's&-.]+[ &]?[\w's&.]+ `)
var str = `Employee's Communications&Engagement, WB
SVP of Global Insights & Analytics, WB
SVP of Nonfiction, HBO Max
VP of Talent Relations and Development, TCM
Global Franchise Management, DC
WB Technology Group
President, EMEA & APAC
SVP & CFO, EMEA & APAC
Director, Service Delivery
SVP for Sales and Client Partnerships, Legacy Turner
Technical Director, WarnerMedia
Dir. of Brand Distribution, WarnerMedia
Dir. Strategic & Consumer Insights, Turner Sports
Manager for Digital Asset & Photo Library, Brand Experience
Creative Manager for Creative Services, Cartoon Network
// 2 words
Cincinnati Bearcats
Miami (FL) Hurricanes
Miami (OH) Redhawks
// three words
South Florida Bulls // 2.1
Duke Blue Devils // 1.2
UNLV Runnin' Rebels // 2.1 with apostrophe
Saint Joseph's Hawks // apostrophe
// 4 words
North Carolina Tar Heels // 2.2
Notre Dame Fighting Irish // 2.2
San Jose State Spartans // 3.1
St John's Red Storm // apostrophe
Florida A&M Rattlers // ampersand Agricultrual Mechanical
William & Mary Tribe // ampersand names
St Francis (PA) Red Flash
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}