re = /(?=.*[0-9])(?=.*[A-Za-z])(?=.*[~!?@#$%^&*_-])[A-Za-z0-9~!?@#$%^&*_-]{8,40}$/m
str = 'ABCabc1$
1^&*TYUh
000000Y*
#AAAAAA9'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end