re = /(?<=device\s)[^""]+/m
str = 'Non-authoritative answer:
"device 0xxxxyyyyyzzzzze"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end