const regex = new RegExp('(\\/\\/i(?:s|)\\d*\\.(?:4cdn|4chan)\\.org\\/\\w+\\/(\\d+\\.(?:jpg|png|gif|webm)))', 'gm')
const str = `http://is2.4chan.org/gif/1559559046386.webm`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}