#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{2}\/(.++\n){3}(?=.+Success)(.++\n){3}(?=.+ABC).++"
Local $sString = "04/09/2018 06:31:59 AM [class | Info] some message received from 101592 (123.123.123.124)" & @CRLF & _
" Request Id: 0 (Descriptor: 0, Operator Request Id: 0)" & @CRLF & _
" A type: bar" & @CRLF & _
" A status: Queued" & @CRLF & _
" The id: 1E25" & @CRLF & _
" Additional info: Inserted in queue at position 1 on device ABC" & @CRLF & _
" Location: ABC, subarea: 2" & @CRLF & _
"04/09/2018 06:31:59 AM [class | Info] some message received from 102364 (123.123.123.123)" & @CRLF & _
" Request Id: 0 (Descriptor: 0, Operator Request Id: 0)" & @CRLF & _
" A type: bar" & @CRLF & _
" A status: Queued" & @CRLF & _
" The id: 1E25" & @CRLF & _
" Additional info: Inserted in queue at position 1 on device ABC" & @CRLF & _
" Location: ABC, subarea: 2" & @CRLF & _
"04/09/2018 06:31:59 AM [class | Info] some message received from 102364 (123.123.123.123)" & @CRLF & _
" Request Id: 0 (Descriptor: 0, Operator Request Id: 0)" & @CRLF & _
" A type: blah bit foo" & @CRLF & _
" A status: Success" & @CRLF & _
" The id: T908" & @CRLF & _
" Additional info: " & @CRLF & _
" Location: DEF, subarea: 3" & @CRLF & _
"04/09/2018 06:32:00 AM [class | Info] some message received from 102364 (123.123.123.123)" & @CRLF & _
" Request Id: 0 (Descriptor: 0, Operator Request Id: 0)" & @CRLF & _
" A type: bar" & @CRLF & _
" A status: Success" & @CRLF & _
" The id: DG08" & @CRLF & _
" Additional info: " & @CRLF & _
" Location: ABC, subarea: 1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")