re = /(?:\b(?:AND|OR|NOT)\b|"[^"\\]*(?:\\.[^"\\]*)*")(*SKIP)(*F)|\w+/m
str = 'Visualise AND Visionary OR "Experiences Tester" OR "\\"Experiences Tester\\"" OR (project AND manager)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end