$re = '/([A-Z]{2})(\d{10})\D*(\d*)/';
$str = 'RC9999999999A202';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);