import re
regex = re.compile(r"(?<=^# .*⤵)\n(^## .*)\n([\s\S]+?)(?=^## .*)", flags=re.MULTILINE)
test_str = ("# Heading 1 ⤵\n"
"## Heading 1.1\n"
"Text of Heading 1.1\n"
"Text can span over multiple lines\n"
"Even more text\n"
"## Heading 1.2 \n"
"Text of Heading 1.2\n"
"# Heading 2\n"
"## Heading 2.1\n"
"Text of Heading 2.1\n"
"## Heading 2.2\n"
"Text of Heading 2.2\n"
"# Heading 3 ⤵\n"
"## Heading 3.1\n"
"Text of Heading 3.1\n"
"## Heading 3.2\n"
"Text of Heading 3.2\n"
"# Heading 4")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")