re = /^([^\[\.]+)(?:\[([^\]]+)])?\.([^{\r\n]+)(?:{([^}\r\n]+)})?$/m
str = 'test.this
test[extra].this
test[extra].this{data}
test.this{data}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end