$re = '@[a-zA-Z0-9$&%\*\+\-/]{1,12}@';
$str = '1234567890123456789';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);