const regex = /[+(]?\d(?:[-()+\s.]*\d){8,14}(?![-()+\s.]*\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[+(]?\\d(?:[-()+\\s.]*\\d){8,14}(?![-()+\\s.]*\\d)', 'gm')
const str = `blabla 01 02 03 04 05 blabla 0102030405 blabla +33102030405 blabla 01-02-03-04-05 blabla 01.02.03.04.05 blabla +33 1 02 03 04 05 blabla (33)102030405`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}