const regex = /(?ms)(?:\G(?!\A)\s*,\s*|EventCode=(411|512)\n.*?\R)\K(?P<src_ip>(?:\d{1,3}\.){3}(?:\d{1,3})|(?:::)?(?:[\dA-Fa-f]{1,4}:{1,2}){1,7}[\d%A-Fa-f.]*(?:::)?|::[\dA-Fa-f.]{1,15}|::)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?ms)(?:\\G(?!\\A)\\s*,\\s*|EventCode=(411|512)\\n.*?\\R)\\K(?P<src_ip>(?:\\d{1,3}\\.){3}(?:\\d{1,3})|(?:::)?(?:[\\dA-Fa-f]{1,4}:{1,2}){1,7}[\\d%A-Fa-f.]*(?:::)?|::[\\dA-Fa-f.]{1,15}|::)', 'gm')
const str = `EventCode=411
EventType=0
Type=Information
SidType=1
TaskCategory=Printers
OpCode=Info
Token Type:
http://schemas.microsoft.com/ws/2006/05/identitymodel/tokens/UserName
Client IP:
110.19.100.155,2603:1032:205:14::5
Error message:
******-This user can't sign in because this account is currently disabled `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}