using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(CREATE\s+TABLE\s+(\w+)\s*;\s*ALTER\s+TABLE\s+\2\s*;)";
string input = @"CREATE TABLE ABC;
ALTER TABLE ABC;";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}