package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)([a-z]+)\s+([0-9]+)`)
var str = `Legal Leaves 2017`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}