const regex = /(?<=\bfor )(?![^;]*\bfor\b)[^;]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\bfor )(?![^;]*\\bfor\\b)[^;]+', 'gm')
const str = `Data Owner Approval Needed for Access Request #: 2137352 for NISHER HOSE; CONTRACTOR; Manager: MUILLER, TIM (TWM0069)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}