$re = '/[ \(]+([a-z])/m';
$str = 'I\'m an example (for stack overflow).';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);