$re = '/((0?[1-9])|(1[0-2]))\/(\d{4})/';
$str = '1/2017
01/2017
12/2017';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);