const regex = /(?:^|[^\/\d])\K(?:0?[1-9]|1[0-2])\/\d{4}\b/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|[^\\\/\\d])\\K(?:0?[1-9]|1[0-2])\\\/\\d{4}\\b', 'gi')
const str = `1/2017
01/2017
12/2017
5/21/2017`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}