$re = '/[Gg]{1}0*/m';
$str = 'G00 X0.0 Y0.0 Z-1.0
G01 X1.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);