re = /\|\K[^|]{50,}(?=\|)/m
str = '060801113494|I am writing a string that is longer that 50 characters|1054.70|2020-12-10 10:27:20|My Test|10511078
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end