using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^master|release|tag\/.*$";
string input = @"tag/1.2.1
master/
release
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}