import Foundation
let pattern = #"\s(\w+)\s+\[?\]?(\w)(\w+)\s+`json:"\w+"`"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Author Author `json:"author"`
Footer Footer `json:"footer"`
Title string `json:"title"`
Description string `json:"description"`
Thumbnail Image `json:"thumbnail"`
Image Image `json:"image"`
URL string `json:"url"`
Fields []Field `json:"fields"`
Color int64 `json:"color"`
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"func (b *EmbedB) $1(\L$2 $2$3) *EmbedB {\n\tb.Embed.$1$2 = $2\n\treturn b\n}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)