package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:.city...)([[:alnum:]]+)`)
var str = `{"travelzoo_hotel_name":"Graduate Minneapolis","travelzoo_hotel_id":"223","city":"Minneapolis","country":"USA","sales_manager":"Stephen Conti"}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}