$re = '/\bUSD \K\d+|[A-Z](?=[A-Z]* \d+\b)/m';
$str = 'USD 100
YEN 300';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);