$re = '/{{.*?}}/';
$str = '{{name}} foo
{{balance, money}} foo
{{num, number(minimumFractionDigits: 2)}} foo
{{value, formatter1, formatter2}} foo
{test} foo
foo {bar}}
food {{bar}
[[test]] me
<xml> too';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);