re = /^(go|goto|gotothe|move|moveto|movethe)(last|previous|next|down)(.*?)(word[s]?|line[s]?|sentence[s]?|paragraph[s]?|para[s]?|char[s]?|character[s]?|space|\n\n|\n)$/m
str = 'golast4word
gotolastspace
movedown
movetheprevious4words
movetodown3
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end