const regex = /(?<=.)[^@\n](?=[^@\n]*?[^@\n]@)|(?:(?<=@.)|(?!^)\G(?=[^@\n]*$)).(?=.*[^@\n]\.)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=.)[^@\\n](?=[^@\\n]*?[^@\\n]@)|(?:(?<=@.)|(?!^)\\G(?=[^@\\n]*$)).(?=.*[^@\\n]\\.)', 'gm')
const str = `john.doe@example.en.com`;
const subst = `*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);