re = /(.*)\n.*$/
str = 'Sample 1
James B. Lapointe
1481 Keyser Ridge Road
Appartment Keyser Ridge Road
Archdale, NC 27263
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end