using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*\[\s*([^\s\r\n:]+)\s*:\s*""([^""]*)""\s*([^\s\r\n:]+)\s*:\s*""([^""]*)""\s*\]\s*$";
string input = @"[description:""aoeu"" uuid:""123sth""]
[description : ""aoeu"" uuid: ""123sth""]
[ description : ""aoeu"" uuid: ""123sth"" ]
[ description : ""aoeu"" uuid : ""123sth"" ]
[ description : ""aoeu""uuid : ""123sth"" ] ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}