use strict;
my $str = '<!-- Comments Testing -->
<div id="page"><div id="header"><h1><a href="#">Burger Pointer</a></h1><ul class="left"><li><a href="#">Menu</a></li><li><a href="#">Location</a></li><li><a href="#">About Us</a></li><li><a href="#">BP Gear</a></li></ul></div></div>';
my $regex = qr/(?!<\/a|<\/h1)((<)(\/|)([a-zA-Z-Z0-9]+))/p;
my $subst = '\\n\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";