$re = '/(?<=i_).*?(?=(?:_[^_]*)?$)/m';
$str = 'i_123_Mobile
i_123_ab_Mobile
i_443aa_ffgfdgsd_Desktop
i_sdfa34214';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);