import re
regex = re.compile(r"(?<!^| ) (\w+?)(?:\r\n?|\n|\z)")
test_str = ("Some line of text ending witha line terminator\n"
"Always find the lsat word with or without a line terminator not including a space\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")