package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[-+]?[0-9]*\.?[0-9]+`)
var str = `-1.2 2 3.5 3
1 2 3 4
34 5.7 3 2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}