import re
regex = re.compile(r"⏰ Timeframe M5((\s+(.*)\s+){1,})⏰ Timeframe M15", flags=re.MULTILINE)
test_str = ("💎 SINAIS VIP - GOLD 🔥:\n"
"⏰ O horário dos sinais é o momento de entrada. O tempo de expiração está no começo do sinal. Entre 2 segundos antes para evitar delay\n\n"
"- - - - - - - - - - - - - -- - - - - - - - - - - - - -\n"
"🔔 Sinais para o dia 06/02/23\n"
"- - - - - - - - - - - - - - - - - - - - - - - - - - - -\n\n"
"SINAIS SEM MARTINGALE\n\n"
"⏰ Timeframe M5\n\n"
"04:05 - EURUSD - PUT \n"
"04:05 - gbpchf - PUT \n"
"06:35 - EURGBP - PUT \n"
"07:10 - EURUSD - PUT️ \n"
"08:15 - EURJPY - PUT \n"
"08:45 - EURGBP - PUT \n"
"09:55 - EURUSD - PUT \n"
"09:10 - AUDJPY - PUT \n"
"10:55 - AUDUSD - PUT️ \n"
"11:10 - USDCAD - PUT \n"
"12:55 : AUDCAD - PUT️ \n"
"14:15 - EURUSD - PUT \n\n\n"
"⏰ Timeframe M15\n\n"
"04:30 - EURUSD - PUT️ \n"
"05:30 - AUDCAD - PUT \n"
"06:15 - EURGBP - PUT \n"
"07:15 - EURUSD - CALL \n"
"08:00 - GBPJPY - CALL \n"
"10:15 - EURUSD - CALL \n"
"11:00 - AUDUSD - PUT\n"
"11:45 - EURJPY - PUT \n"
"12:30 - EURUSD - PUT \n"
"14:45 - EURUSD - PUT \n\n"
"- - - - - - - - - - - - - -- - - - - - - - - - - - - -\n"
"⚠️ Não opere contra a tendência\n\n"
"Cadastre-se na quotex é ganhe um bônus de deposito sobre o seu valor.\n\n"
"https://quotex.io/sign-up/fast/?lid=61838\n"
"quotex.io\n"
"Quotex: An innovative platform for online investment\n"
"Quotex is an innovative platform with up to 98% return on every investment! Sign up for a demo account to practice with $10,000. With a minimum deposi...")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")