import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Kerberos\\-wsfed:.+?Mean:\\s+(\\d+)";
final String string = "Kerberos:\n"
+ " Historical:\n"
+ " Between 26 and 50 milliseconds: 10262\n"
+ " Between 50 and 100 milliseconds: 658\n"
+ " Between 101 and 200 milliseconds: 9406\n"
+ " Between 201 and 500 milliseconds: 6046\n"
+ " Between 501 milliseconds and 1 second: 1646\n"
+ " Between 1 and 5 seconds: 1399\n"
+ " Between 6 and 10 seconds: 13\n"
+ " Between 11 and 30 seconds: 34\n"
+ " Between 31 seconds and 1 minute: 7\n"
+ " Between 1 minute and 2 minutes: 1\n"
+ " Mean: 268, Mode: 36, Median: 123\n"
+ " Total: 29472\n"
+ " Kerberos-wsfed:\n"
+ " Historical:\n"
+ " Between 26 and 50 milliseconds: 3151\n"
+ " Between 50 and 100 milliseconds: 129\n"
+ " Between 101 and 200 milliseconds: 650\n"
+ " Between 201 and 500 milliseconds: 411\n"
+ " Between 501 milliseconds and 1 second: 171\n"
+ " Between 1 and 5 seconds: 119\n"
+ " Between 6 and 10 seconds: 4\n"
+ " Between 11 and 30 seconds: 6\n"
+ " Between 1 minute and 2 minutes: 1\n"
+ " Mean: 176, Mode: 33, Median: 37\n"
+ " Total: 4642";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}