import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\\*|((((count|max|sum|min|avg|version|database|user|round|ceil|floor|truncate|mod)\\((\\*|\\w+|\\s*)\\)\\s?,?\\s?)|(\\w+(.\\w+\\s+,\\s+))){1,}));?)";
final String string = "table4.id , table5.name , table6.name , table7.name , table8.name , table9.name , ddd \n"
+ "((\\s?\\w+(\\.\\w+)?\\s?\\,\\s?)*)\n"
+ "select count(*) , max(table4.id) from table4,table5 left join tab2 on tab1.size = tab2.size , right join tab2 on tab1.size = tab2.size where id <> 1 having dd group by dd order by dd desc dd - 2 > 3;\n"
+ "select user();\n"
+ "select * from user where id = (select * from dd where id = 1);\n"
+ "select count(vdvdvdvfd) from table4,table5 where table4.id=table5.id;\n"
+ "select tt.dd from table4,table5 where table4.id=table5.id;\n"
+ "count(vdvdvdvfd) , max(fdvd) , sum(fdvd) , min(fdvd) , avg(fdvd) , version() , \n\n"
+ "table , count(ff) , table \n"
+ "((\\*|((((count|max|sum|min|avg|version|database|user|round|ceil|floor|truncate|mod)\\((\\*|\\w+|\\s*)\\)\\s?,?\\s?)|(\\w+(.\\w+\\s+,\\s+))){1,}));?)\n\n"
+ "((((count|max|sum|min|avg|version|database|user)\\((\\*|\\w+|\\s*)\\)\\s?,?\\s?){1,});?)\n\n\n"
+ "((\\*|(((count|max|sum|min|avg|version|database|user|round|ceil|floor|truncate|mod)\\((\\*|\\w+|\\s*)\\)\\s?,?\\s?){1,}));?)\n\n\n"
+ "select\\s+(\\*|((\\w+(\\.\\w+)?)+(\\s?,\\s?\\w+(\\.\\w+)?)*)|((\\w+\\([^\\s]|(\\w+\\.\\w+)?\\))(\\s+\\,\\s+)?)+)\\s+from\\s+(\\w+(\\s?,\\s?\\w+)*\\;?)(\\s+((\\w+\\s+join)\\s+(\\w+(\\.\\w)?\\s+on\\s+(\\w+(\\.\\w+)?\\s+=\\s+\\w+(\\.\\w+)?)?)(\\s+,\\s+)?)+)?(\\s+((limit\\s+(\\w+)?\\s?(\\,\\w+\\;)?)|((where)?\\s+?([^\\;]+\\s?;))))?\n\n"
+ "select\\s+(\\*|((\\w+(\\.\\w+)?)+(\\s?,\\s?\\w+(\\.\\w+)?)*)|((\\w+\\([^\\s]|(\\w+\\.\\w+)?\\))(\\s+\\,\\s+)?)+)\\s+from\\s+(\\w+(\\s?,\\s?\\w+)*\\;?)(\\s+((\\w+\\s+join)\\s+(\\w+(\\.\\w)?\\s+on\\s+(\\w+(\\.\\w+)?\\s+=\\s+\\w+(\\.\\w+)?)?)(\\s+,\\s+)?)+)?(\\s+((limit\\s+(\\w+)?\\s?(\\,\\w+\\;)?)|((where)?\\s+?([^\\;]+\\s?;))))?\n\n\n"
+ "select\\s+((\\*|(((count|max|sum|min|avg|version|database|user|round|ceil|floor|truncate|mod)\\((\\*|\\w+|\\s*)\\)\\s?,?\\s?){1,}));?)\\s+from\\s+(\\w+(\\s?,\\s?\\w+)*\\;?)(\\s+((\\w+\\s+join)\\s+(\\w+(\\.\\w)?\\s+on\\s+(\\w+(\\.\\w+)?\\s+=\\s+\\w+(\\.\\w+)?)?)(\\s+,\\s+)?)+)?(\\s+((limit\\s+(\\w+)?\\s?(\\,\\w+\\;)?)|((where)?\\s+?([^\\;]+\\s?;))))?\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}