re = /[!$%^&*()_+|~=`{}\[\]:";'<>?,.]/m
str = 'sample
sample+test
sample++
/sample/test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end